BU030718_EW01

HP Tru64 UNIX Possible Memory Corruption

»

HP Tru64 UNIX

Tru64 UNIX

» Tru64 UNIX V5.1B-6
» Tru64 UNIX V5.1B-5
» Documentation
» Information library
» Software web index
» Software products library
» Patch database
» Services
» Developer & Solution Partner Program
» Send us your comments
» Support Statements

Evolving business value

» Tru64 UNIX to HP-UX 11i transition benefits calculator
» Alpha RetainTrust Program
» Transition

Related links

» Alpha systems
» HP-UX 11i
» Integrity servers
» Linux
» HP storage
» HP solutions
HP-UX 11i: measurably better TCO!
 Advisory Information
 

RELEASE DATE: 06 October 2003

DESCRIPTION
Update: October 2003

This EA is being updated to provide a pointer to a replacement for the 5.1A PK5 (BL23) ERP identified in the original EA.

TThe replacement 5.1A PK5 ERP contains fixes for the following three AdvFS-related issues:

  • HP Tru64 UNIX Possible Memory Corruption, described in this EA
     
  • HP Tru64 UNIX - Errors with V5.1A Patch Kit 5 (BU030910_EW01)
     
  • HP Tru64 UNIX V5.1A PK5 Mandatory Patch for Potential Unexpected AdvFS Domain Behavior (EA BU031001_EW01)
     

Special Installation Instructions

After installing the ERP, users should run fixfdmn on domains that may have become 90% full at any time after PK5 was installed.

The original EA, with the replacement 5.1A PK5 location, follows./p>

______________________________________________________________

Under certain circumstances, memory corruption can occur when a non-Tru64 UNIX NFS client attempts to increase the size of an AdvFS file.

The problem usually appears as a kernel memory fault and corruption in multiple kernel memory buckets. A thread in the crash has the following stack trace segment:

    [...]
        5 _OtsZero
        6 fs_setattr
    [...]

 

SCOPE
The following HP Tru64 UNIX versions are affected:

  • 5.1B PK2
  • 5.1B PK1
  • 5.1B SSB
  • 5.1A PK5
  • 5.1A PK4
 

RESOLUTION
Until the HP Tru64 UNIX corrections are available in the mainstream release patch kits, HP is releasing the following Early Release Patch kits (ERPs) publicly for use by any customer. The ERP kits use dupatch to install and will not install over any Customer Specific Patches (CSPs) that have file intersections with the ERP.  Contact your service provider for assistance if the installation of the ERP is blocked by any of your installed CSPs.

The fixes contained in the ERP kits are scheduled to be available in the following mainstream patch kits: 

  • HPTru64 UNIX 5.1B   PK3 (BL24) 
  • HP Tru64 UNIX 5.1A   PK6 (BL24)   

Early Release Patches

ERP kits are available for the following versions.

HP Tru64 UNIX 5.1B
PREREQUISITE:      HP Tru64 UNIX with 5.1B with PK2 (BL22) installed
ERP Kit Name:        T64KIT0019920-V51BB22-E-20030909
Kit Location:  
http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT0019920-V51BB22-E-20030909  

HP Tru64 UNIX 5.1A
PREREQUISITE:      HP Tru64 UNIX with 5.1A with PK5 (BL23) installed
ERP Kit Name:        T64KIT0020145-V51AB23-E-20031001
Kit Location:  
http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT0020145-V51AB23-E-20031001

HP Tru64 UNIX 5.1A
PREREQUISITE:      HP Tru64 UNIX with 5.1A with PK4 (BL21) installed
ERP Kit Name:        T64KIT0019921-V51AB21-E-20030909
Kit Location:  
http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT0019921-V51AB21-E-20030909