c01149780

HP Tru64 UNIX V5.1B-4 - AdvFS-Related Kernel Memory Fault Panics

»

HP Tru64 UNIX

Tru64 UNIX

» Tru64 UNIX V5.1B-6
» Tru64 UNIX V5.1B-5
» Documentation
» Information library
» Software web index
» Software products library
» Patch database
» Services
» Developer & Solution Partner Program
» Send us your comments
» Support Statements

Evolving business value

» Tru64 UNIX to HP-UX 11i transition benefits calculator
» Alpha RetainTrust Program
» Transition

Related links

» Alpha systems
» HP-UX 11i
» Integrity servers
» Linux
» HP storage
» HP solutions
HP-UX 11i: measurably better TCO!
 Advisory Information
 

LAST UPDATE: 2008-02-27 (version 2)

DESCRIPTION

ATTENTION: This EA clarifies the content of the ERP kit identified in this document. See the Note in the Resolution section for details.

During normal system operations, HP provided utilities may, when simultaneously accessing an AdvFS indexed directory, create conditions that cause kernel memory fault panics.

The known stack traces are:

0 boot
1 panic
2 trap
3 _XentMM
4 access_invalidate
5 bfs_dealloc
6 bfs_close
7 bs_bfs_close
8 msfs_unmount
9 do_pfs_unmount
10 cfs_stop_server_accept
11 cms_handle_send_msg
12 cms_kgs_callback_thread

(Note: the panic string for the following panic is "neg refCnt")

0 stop_secondary_cpu
1 panic
2 event_timeout
3 printf
4 panic
5 advfs_sad
6 free_acc_struct
7 bs_close_one
8 idx_close_index_file
9 msfs_inactive
10 vrele
11 namei
12 _F64_stat1
13 syscall
14 _Xsyscall

and

0 boot
1 panic
2 trap
3 _XentMM
4 bs_get_bf_page_cnt
5 msfs_syscall_op_tag_stat
6 msfs_real_syscall
7 msfs_syscall
8 syscall
9 _Xsyscall

 
SCOPE

HP Tru64 UNIX v 5.1B-4 is the only affected version.

 
RESOLUTION

HP is releasing the following Early Release Patch (ERP) kit publicly for use by any customer. The ERP kit uses dupatch to install and will not install over any customer-specific patches (CSPs) that have file intersections with the ERP. Contact your service provider for assistance if the installation of an ERP is blocked by any of your installed CSPs.

NOTE: ERP kit T64KIT1001178-V51BB27-E-20070330.tar, which was released in EA c00892205, is included in the ERP kit identified in this document.

The fix contained in this ERP kit is targeted for availability in the following mainstream patch kit:

HP Tru64 UNIX 5.1B-5

Early Release Patch

HP Tru64 UNIX version: 5.1B-4
ERP Kit Name: T64KIT1001279-V51BB27-E-20070817
Kit Location:
http://www.itrc.hp.com/service/patch/patchDetail.do?patchid=T64KIT1001279-V51BB27-E-20070817